Null sender
Een lege envelope-afzender, geschreven als MAIL FROM:<>, gebruikt voor bounces en andere meldingen zodat die nooit zelf een bounce kunnen veroorzaken.
Wat het betekent
RFC 5321 verplicht dat non-delivery notifications met een null reverse-path worden verstuurd, en andere delivery status notifications en leesbevestigingen gebruiken het ook; elk ander bericht hoort een echte envelope-afzender te hebben. Een server mag geen melding sturen over een bericht met een lege envelope-afzender, en dat voorkomt dat bounces heen en weer blijven bouncen.
Omdat er geen afzenderadres te controleren is, evalueert SPF in plaats daarvan postmaster op de HELO-naam. De SMTP-relaydienst van Google accepteert geen meerdere envelope-ontvangers als de envelope-afzender leeg is. Automatische responders mogen niet op zulke berichten antwoorden (RFC 3834), en gewone mail hoort nooit met <> te worden verstuurd.
Voorbeeld
MAIL FROM:<>Verwante begrippen
Bronnen
Waar deze definitie op steunt. De formulering is van ons, de feiten zijn van hen.
- RFC 5321, section 4.5.5: Messages with a Null Reverse-Pathrfc-editor.org
- RFC 5321, section 6.1: Reliable Delivery and Replies by Emailrfc-editor.org
- RFC 7208, section 2.4: The "MAIL FROM" Identityrfc-editor.org
- RFC 3834, section 2: When (not) to send automatic responsesrfc-editor.org
- Google Workspace Admin Help: Route outgoing SMTP relay messages through Googleknowledge.workspace.google.com
Alle 432 begrippen in de begrippenlijstDe wiki: blacklists en bouncecodes